Tag Archives: Web Developer Server

Web-Developer Server Suite v1.95 Released

Web-Developer Server Suite at SourceForge.NET

Version Updates…
Apache 2.2.4 over 2.2.3
PHP 5.2.1 over 5.2.0
MySQL 5.0.37 over 5.0.27
OpenSSL 0.9.8e over 0.9.8d

mod_security 2.1.0 over 2.0.4 [with core ruleset]
mod_perl 2.0.3 over 2.0.2

phpMyAdmin 2.10.0.2 over 2.9.2

Drupal 5.1.0 over 5.0
MediaWiki 1.9.3 over 1.9.0
WordPress 2.1.2 over 2.0.7

Added…
mod_fastcgi v2.4.2 [SNAP-0404142202, 14-Apr-2004]

Removed…
Tomcat/mod_jk, PHP4, mod_aspdotnet have been removed. Will be packaged as component addons from separate downloads.

Web-Developer Server Suite v1.94 Released [on SourceForge]

Web-Developer Server Suite at SourceForge.NET

phpMyAdmin has been updated and a major issue resolved. Hopefully this release also brings the random IE problems to a close.

All the Web-Framework Applications have been updated to their current versions. Drupal 5.0 is now in, over the 4.7 branch.

I’m looking for other developers to joint this project…

Contact:
devside_net at users.sourceforge.net

We are on SourceForge!

http://sourceforge.net/projects/webdeveloper

I encourage anyone and everyone capable, to join in the process of moving the project forward… Wherever that might go.

I’m looking for other developers to become part of the project. All work will be GPL’ed. You must be able to integrate and configure some subset of the current component base. All builds should be made with…

The components are built with VC++ 6.0, Service Pack 5, Processor Pack (MASM), and the Feb 2003 Platform SDK (the last ‘official’ VC6.0 PSDK). This is the same toolchain that ‘official’ release builds of Apache, MySQL, PHP, etc, are compiled under. VS.NET is avoided, to prevent mixing runtimes between major components, except for mod_aspdotnet builds.

Components that are already built with VC++ 6.0, such as Apache and PHP, we integrate as binaries — no need to build from source.

VS.NET 2002/2003 [and not 2005] is also needed to build mod_aspdotnet.

Developers skilled with ASP, Perl, and JSP [Tomcat] that can install, integrate, configure mod_aspdotnet, perl, mod_perl, perl-modules, and Tomcat/mod_jk are needed.

C/C++ developers for the Web-Developer Controller are needed.

If anyone wants to maintain a VS.NET build, you are needed.

If you can work on documentation and know the difference between things such as “its” and “it’s”, you are needed.

I think the next release, v1.94, might be put out on SF. Though there are still some minor licensing issues to deal with.

Also, the Web-Developer Controller needs to be GPL’ed to be distributed with the project. I would just do it, but the code needs to be cleaned up significantly before I would want to show it to anyone. It might make it in into v1.94, or it might have to be distributed separately for the time being.

So if you think you have the right stuff, AFTER you see a release on SF, contact me at admin @ devside.net. Right now there is too much to do and the future is always uncertain.

If you are skilled in C/C++, and can handle a few thousand lines if poorly written win32 api code spread across header files with some crazy looking stuff, you may contact me anytime you wish and take a great burden of my shoulders. Be warned though, you may never be the same. Ever see anyone duplicate all the handles on the system for no good reason?

Maybe thats a good thing though, about the code I mean… No one will be able to integrate it into another WAMP distro, GPL or not.