MySQL 5.7 Start Error “TryAcquireSRWLockExclusive could not be located…”

mysqld error TryAcquireSRWLockExclusive

Supported OS

MySQL 5.7 no longer supports Windows Vista nor Server 2008 (nor the 32 bit version of Server 2008 R2). This is the cause of the above error message.

MySQL 5.7 supports Windows 7 and upwards, and Server 2008 R2 (64 bits) and upwards.

Built For Runtime

MySQL 5.7 also now uses the Windows Visual Studio 2013 (VC++ 12.0) run-time, which is not present on some systems and will require installation.

Other Changes

Also for those downloading the “no install” zip package (vs. the msi-installation package) of MySQL 5.7, note that this package no longer contains the expected:

Leave a Reply

Your email address will not be published.

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>